Garmin 201 problem

7 messages
18/09/2006 at 20:40
Hi Guys I have a Garmin 201 and it's nearly 2 years old. The problem is that its just gone "dead" on me. When I try to charge it I don't get anything at all. Before I used to get the " battery charging in progress" message but now nothing.I can't check to see if the charger is working and I don't know what to do now.

Any advice?
18/09/2006 at 22:47
Maybe your contacts are dirty? I've read on here somewhere to try cleaning them with a rubber. It would explain why you're not getting a message - cos your Garmin doesn't realise the charger's attached.
19/09/2006 at 10:11
Hi Stylish this is exactly what's happened to me - it just went dead a few weeks ago and refuses to power up.

The book of words says if it's completely juiced out you should plug it in and leave it for half an hour until the 'battery charging in progress' message comes on - I did, and it didn't.

Not sure where you live but I work in London and took it back to Ask electronics on Tottenham Court Road - no receipt but bought (like yours?) Dec 2004. They took it in to send to Garmin, reporting it as still under warranty and undertook to let me know within 10-14 days, great service so far. Fingers crossed they can fix it, ASk said their servicing is very prompt and reliable.
19/09/2006 at 19:33
Thanks guys. I bought mine over the internet from Heartratemonitor.co.uk.I'll try and contact them. Alcopop let me know how you get on. I might try the same route.
10/10/2006 at 10:01
Ok Stylish you can breathe out now...

Got a call at the weekend to be told they have replaced it free of charge. Will go and pick it up at lunchtime today - hopefully ASK will not add on any fee!

Took 17 days rather than the 10-14 promised but for a full replacement I'm not going to argue.

If you need their number please let me know.

See you at Abingdon!

Cheerful Dave    pirate
10/10/2006 at 14:32
I had the same problem after a year and Garmin replaced it no problem. A lot of people seem to have the same thing go wrong, I wonder if it's a design flaw with the 201, possibly with sweat shorting out the contacts. I always make sure i've wiped them clean after a run and so far the replacement has been fine.

11/10/2006 at 14:49
My 201 won't pick up a signal and I've just about given up. I have stood in the middle of a field for an hour - got a signal moved 2 foot and lost it again! I've contacted Garmin several times but had no joy yet with a response and don't know what to do now. My OH got the garmin from a shop on Ebay that we think is now out of business(surprise surprise!!). Any suggestions would be gratefully received before I throw the darn thing out!

We'd love you to add a comment! Please login or take half a minute to register as a free member
7 messages
Previously bookmarked threads are now visible in "Followed Threads". You can also manage notifications on these threads from the "Forum Settings" section of your profile settings page to prevent being sent an email when a reply is made.
Forum Jump  

RW competitions

RW Forums