Garmin Connect Lap time Issue

Recent problem with average laptime displayed in Garmin Connect

21 to 22 of 22 messages
17/03/2014 at 16:07

I'm relieved to hear that others are having the same problems as me. My watch displays the correct times, but when uploaded to Garmin Connect the time taken is way out! I'm pretty certain I'm not running a km in two and a half minutes! the lap splits are showing correctly. It's really frustrating as I do like to compare similar activities. Grr. 

Yesterday at 13:46

After reading your posts in here and posts elsewhere, it became apparent that I am not the only one with issues with Garmin.

Problems with the device (305) and with Garmin upload continue.

Device takes ages to connect with GPS. I have to switch it on and leave it outdoors for over an hour sometimes for it to connect with GPS.

Garmin Site  doesn't work properly and the upload doesn't take place and if it took place there is always a discrepancy between the data recorded on the device and the data appearing after the upload. 

Customer Service is an absolute disaster over the phone and after over an hour trying to repeat myself and the problem, the very unhelpful lady was adamant that the device is not faulty(not sure how she figured that out over the phone) and the problem is with the site. Finally she has conceded that I should send the device for service. Reading on other forums, similar problems with Garmin site date back to 2011.

3 weeks later, I receive an email indicating that the device was sent back and no error has been found.

2 weeks waiting time (after the additional 3 weeks when the device was with Garmin) and no device has arrived.

I rang them and the same unhelpful person who answered my first and second call indicated that she cannot find the device but she'll get back to me once she finds it.

No contact has been made but 4 days later the device was posted via recorded courier and arrived within 24 hrs however with the same exact problems.

I hasten to add that this is a replacement device as the first device died on me within a few months after purchasing it from a reputed London store, it was sent back to Garmin as per their advice and I have instead received this faulty device.

Looks like Garmin are having serious issues and they are unable to cope and/or troubleshoot the numerous problems that have been reported by the users.

In my experience, using Garmin has been a waste of time, money, and an added frustration from Garmin support.

I will avoid Garmin and currently Iam looking for an effective and reliable device as well as download and service.

Edited: 20/04/2014 at 14:00

We'd love you to add a comment! Please login or take half a minute to register as a free member
21 to 22 of 22 messages
Previously bookmarked threads are now visible in "Followed Threads". You can also manage notifications on these threads from the "Forum Settings" section of your profile settings page to prevent being sent an email when a reply is made.
Forum Jump  

RW Forums