Garmin Forerunner 305 problems anyone else ?

Anyone esle having a problem with their new forerunner 305

261 to 280 of 293 messages
06/02/2008 at 11:30
As far as i know there is not a way to turn up the alarm volume!
06/02/2008 at 21:19

Beginner to Forerunner 305. Fantastic motivation tool ! Struggling a bit with Garmin Training Center. Have really given up and converted to MotionBased.

How do I update a Course with new time? In search of continous improvement it would be nice to always run a course against "best" time, and not "first" time.

08/02/2008 at 17:35

Why not save new time with another name/number and bin the previous one?

Or have several times for the same course depending on how far you want to push yourself

10/02/2008 at 22:59
Thanks OOK! 2 good tips.
CL
11/02/2008 at 09:10

I thought my 305 had died yesterday: couldn't switch it on and the computer didn't acknowledge it existed. I was going to send it back today, but it started charging when I turned on the computer. So, two questions:

1. Does yesterday's problem suggest it's on the way out anyway?

2. If I do send it back, should I deal direct with Garmin, as some appear to have, or with the dealer that sold it to me? (I've emailed the dealer; waiting for a reply.) 

20/02/2008 at 18:54

Hi,

Sorry can't read all the posts on this thread. Wondered if anyone had had problems with the Garmin 205 counting backwards.   Went out on a 10mile run on saturday and after about 7 miles it started counting backwards.  At this point I was retracing my steps from the start of my run but surely it shouldn't cancel itself out?  Also when I put in onto computer it claims my top speed was 45mph!!!!  I've had it for about 18 months now so probably not under warrantee.

Can anyone help!

17/05/2008 at 12:48

Can you help- can't seem to find the answer to this question- so it must be dead straight forward!!

How do I turn the virtual trainin partner on?  I seem to have switched it on in options but when I'm in quick workouts he/she doesn't appear- they keep standing me up!!

 I am gettin quite paranoid is it me doesn't the partner like me, was it something I said or something I am wearing?

Please help

17/05/2008 at 21:52
I've been having a problem with Garmin Training Centre for the last few weeks when I click it on on computer it looks like it's starting up then just disappears and try again and again but nothing. The last time I had used it was 6-8 weeks previous and no probs then.  I've even tried removing the programme and installing but same thing happens.  Anyone had this or know how to rectify it.
19/05/2008 at 17:47
I have had problems with my 305 locating satellites - it became increasingly slow and then on sunday it was going for nearly an hour without getting a lock . Ive only had it a few weeks but a software re install seems to have cured it for the time being. Has anyone else had problems ?
19/05/2008 at 21:53

BB when you start your timer for the quick workout., use the scroll buttons up and down and you should see the virtual partner after all the usual pace & heart rate windows etc.

Can't help with the other 2 problems I'm afraid.

Edited: 19/05/2008 at 21:55
20/05/2008 at 18:12

Thanks a lot Mr Puffy- found him- brilliant where has he been all my life.

 cheers

18/06/2008 at 10:58

CL - the exact same problem has happened to my 305 yesterday!!  I downloaded my run last night and then later i couldn't switch the device on and the computer wouldn't ackowledge it. I brought it into work today to talk to Garmin, plugged it into my work PC for one last check and surprise ... it started charging.

I certainly hope it isn't a sign off it on it's way out, but when i had a problem in the past i dealt direct with Garmin and they were great.

JH1 - I use Training Centre and Sports Track. Training Centre doesnt always seem to recognise the runs and i'm never sure if the devise should be on or off but i usually get it to work. So i cant really ehlp you. However, i only use TC as it starts up automatically. My advice would be to look at Sports Track i think it's far better, and if nothing else is a back up to TC.

02/07/2008 at 01:15
My 305 is 2 to 3 years old, I've had no problems whatsoever (apart from losing sync with the satelite on the odd occassion) but this morning I was warming up on the treadmill prior to a "spinning class", had my 305 on "indoors mode" (not tracking the satelite), after a couple of minutes, the watch screen started to flicker with all different views of the watch face, I could not do anything with it, turn it off, use different modes, scroll up or down etc The watch eventually died, most probably run out of juice !. I tried turning it back on but I had no joy, I tried connecting it to my pc but my pc rejected it as well !

Has anyone experienced this sort of behaviour before with the 305 ?
02/07/2008 at 09:53
Ok, not sure if this has been covered but after this mornings run I uploaded the data to TC, it recognised the run but couldn't produce any graphs.  I tried Motionbased and then Sporttracks on the work PC but neither of them recognised the run so wouldn't upload the data.  This is the first time I've ever had this problem, anyone else experienced this?
02/07/2008 at 11:50

Hi. Has anyone had a poblem with their Garmin regarding workouts and pace alerts?I started the RW training schedule on Monday and set off to a run between 8:10 and 8:30 a mile. The alert started just after I started(understandibly) telling me to speed up.After I got in the right zone up popped another message stating I was at the correct pace. After that I never go anther response even though I checked and at one point I going 7:45 a mile. I had the same problem yesterday and today.I even  deliberately averaged 8.00 a mile just to see if I was told to slow down, but there was no response.

Any suggestions?

Thanks.

04/07/2008 at 09:25

A slight update on the above: I ran a 4 mile temp yesterday-7:16-7:36 pace. This tiem I started down hill and was running 7:50 amile and was told by the Garmin to slow down! Once I did and entered the correct pace, I got the beep and once again no more was heard even though at one point I was averaging 7:08 a mile.It seems to stop alerting once I am touched  the correct zone.

BTW if it were working correctly would it alert me if my pace was above/below the setting or if my average pace for the distance was above/below?

04/07/2008 at 15:59

I have a feeling mine may do the same, but I wear an ipod when out so just keep giving it quick glances.  It definitely keeps beeping when I'm going too slow to begin with, not quite sure what it does when I'm in the zone though, but your problem sounds familiar.

I'll check it out on my next run.

04/07/2008 at 20:46
My 305 is happily downloading data to TC and showing graphs etc all like normal however when I close it down, it is failing to save the data for my current week.  Had it for a couple of months and no probs up to now.  SportTracks is working fine with these dates and runs.  Any thoughts- it's not as if you have to save the data in TC, well not up till now? Help please.
22/07/2008 at 21:03
straitjacket wrote (see)

A slight update on the above: I ran a 4 mile temp yesterday-7:16-7:36 pace. This tiem I started down hill and was running 7:50 amile and was told by the Garmin to slow down! Once I did and entered the correct pace, I got the beep and once again no more was heard even though at one point I was averaging 7:08 a mile.It seems to stop alerting once I am touched  the correct zone.


Ok, I remembered to try this on the warmdown mile after my intervals this morning, exactly the same thing, kept telling me to slo down, I entered the correct zone and then sped up well outside of the desired zone.  Nothing.
23/07/2008 at 07:53

I have not used the pace zone function as i trained with Hear Rate zones, never a prob for me with HRZ, i get beep if i exceed or go below the set limits, worth for you guys to try the HRZ, even just for mile or two & see if you face the same problem?

261 to 280 of 293 messages
Previously bookmarked threads are now visible in "Followed Threads". You can also manage notifications on these threads from the "Forum Settings" section of your profile settings page to prevent being sent an email when a reply is made.
Forum Jump  

RW Forums