'Installing' Garmin Communicator Plugin

Cannot get it to install on Windows 7 for a 305

6 messages
08/01/2011 at 20:42
Right, there's a couple of issues I went though.
Are you using Chrome as your web browser to check it?
If so it won't work by default as it's not listed as a supported browser. However if you install the Chrome User Agent switcher
https://chrome.google.com/extensions/detail/aafciojnlamllgpkpdkbamkfgbofhgcj
you can then make chrome temporally pretend to be Internet Explorer which should make garmin connect work.

Alternatively, if you are already using internet explorer, you need to make a couple of security changes.
Click on Tools/Internet Options in IE, click on the security tab, then trusted sites, then the sites button.
Then add
https://buy.garmin.com and
https://connect.garmin.com

Save, restart IE and then try reinstalling garmin connect.

Edited: 08/01/2011 at 20:44
08/01/2011 at 21:40
Good luck!!!
09/01/2011 at 08:29
Bit of a long shot but I had problems when I installed it but only because IE was left open and running on a second user account that was still logged on. It seemed to have installed but I got the same issue as you - when I used the test page it said it wasn't.

I switched user, closed that IE instance and then went back downloaded it again, saved it to the hard disk, closed IE and then ran the downloaded file and it worked fine.

The other thing is that despite what it says on the Garmin page it seems to work about 95% of the time with Chrome. Occasionally I have to have 2 goes at uploading a workout.. but then I think I have had the same issue with IE.

Under both IE and Chrome running the test page "http://www8.garmin.com/products/communicator/test/" shows a message

"Communicator Plugin is properly installed and up to date, version 2.9.3.0.
Garmin GPS device is detected and communicating properly:"

I've uploaded workouts from my 305 to several 3rd Party sites as well as Garmins own site on Chrome so it all seems good.

Maybe I already have "Chrome User Agent Switcher" as Ian M suggests but I haven't done that as an "add on" or changed any settings so unless it is part of the latest version of Chrome and happens automatically then I haven't had to do anything.

Good luck.
09/01/2011 at 15:55
Oh well. Thought it might be a long shot :-]

You are right - IE and Chrome aren't exactly "niche products" so you would have expected them to be the first browsers Garmin would get working.

What is strange is that it seems to be so inconsistent. I am using a Dell laptop running Windows 7 and IE 8 (or Chrome 8.0.552.224)and apart from a few lockups it works for me 95% of the time. Wonder what settings I have accidentally (and fortunately) enabled !

Still - I hope that now you have Firefox installed that you don't have any more problems - I guess you only have to use Firefox to upload the data. After that you can use the others to review the data :-]

Hope you are happy with your Garmin other than the slightly flaky "communicator" software. I have had mine a few months and I love it. Recently bought the footpod so that I can use it on the enforced treadmill runs and it is fantastic.



21/02/2013 at 15:37

Finally - Go to Chrome Settings, Advanced Settings, Privacy, Content Settings, Plugins and Check  "Run Automatically". This fixed it for me in Chrome. In addition to having IE set as my default Browser (will change it back to Chrome now). Hope that helps.

21/02/2013 at 15:41

I think JT may have sorted the issue between the time of her last post and yours Kapil - she's had over 2 years to do so......


We'd love you to add a comment! Please login or take half a minute to register as a free member
6 messages
Previously bookmarked threads are now visible in "Followed Threads". You can also manage notifications on these threads from the "Forum Settings" section of your profile settings page to prevent being sent an email when a reply is made.
Forum Jump  

RW competitions

RW Forums