is my garmin past saving?

query/advice welcome

9 messages
06/06/2013 at 00:13

have had problems getting a signal recently and been hard work uploading to fetch, noticed tonight that there was some corrosion on one of the connections. it manages to upload to training centre no problem but struggles with fetch(not at all tonight) so wondering if its beyond fixing or if there's something i could try to sort it? anyone had similar problems?

06/06/2013 at 05:28

WD40

M...eldy    pirate
06/06/2013 at 05:56

If it connects to the training centre but not to Fetch then I would guess that its Fetch that has the problem?

06/06/2013 at 07:56

scraped off corrosion or whatever it was and managed to upoad to fetch this morning! not sure how much longer i'll get out of it, but will be on the lookout for a bargain now!

06/06/2013 at 08:27

Mine's a 310. Don't know if it's the same issue with yours, I was thinking mine was on the way out, having trouble uploading, sometimes it would, sometimes it wouldn't. Kept re-installing the drivers etc. kept cleaning the contacts. Then a friend suggested I try a new holder, borrowed a fairly new off another friend and hey presto, no more issue. Shelled out a few quid for a new holder, rather than a few hundred for a new 910 (was kinda hoping I had an excuse to get a 910 but it wasn't to be!). 

As for signal, couldn't tell you. I put it outside while I get my act together, which can sometimes be a while.......

06/06/2013 at 16:06

Not tried it yet, but did see a website which recommended cleaning the contacts with a pencil eraser periodically/when connecting is difficult.

06/06/2013 at 22:24

thanks will try these things, not playing ball again this evening but not given up just yet! like the idea of getting a shiney new garmin but not if its unnecessary.

25/06/2013 at 11:13

I have trouble uploading my 305 forerunner occasionally. 

I realised that whenever I took my watch off with out wiping the contacts then I would have a problem later uploading. So its as if the sweat dries and leaves a layer on the contacts preventing a proper connection. 

but also I have read that periodically deleting all the history speeds up the transfer. 

 

oh, sorry what am I saying. It's knackered mate, go and buy a shiny  new garmin

25/06/2013 at 22:51

no chance of a new garmin, they even went as far as creating a new garmin importer on fetcheveryone so my old 205 would still upload! may treat myself eventually?


We'd love you to add a comment! Please login or take half a minute to register as a free member
9 messages
Previously bookmarked threads are now visible in "Followed Threads". You can also manage notifications on these threads from the "Forum Settings" section of your profile settings page to prevent being sent an email when a reply is made.
Forum Jump  

RW competitions

RW Forums